วิธีการบังคับใช้ DNS Server จาก Mikrotik Router ของเรา

วิธีการบังคับใช้ DNS Server จาก Mikrotik Router ของเรา พอดีวันนี้ได้โจทย์ใหม่มาก็คือภายในองค์กรมีการใช้งาน Intranet Site (เว็บไซต์ภายใน) โดยการ Add DNS Record แบบ Static ไว้ภายในตัว DNS Server ของ Mikrotik เพื่อให้ลูกข่ายรู้จักและวิ่งไปยัง Intranet เหล่านี้ได้
ซึ่งวันนี้ปรากฎว่ามีคอมพิวเตอร์ของเจ้าหน้าที่ซึ่งหิ้วมาจากที่บ้านไปตั้งใช้ DNS ของ Google เอาไว้ ส่งผลให้เมื่อเชื่อมต่อกับเครือข่ายขององค์กรแล้ว ไม่สามารถเข้าใช้ Intranet ได้ เพราะ DNS ของ Google ไม่รู้จัก Intranet เหล่านี้
   จึงแก้ปัญหาด้วยการเซ็ต Firewall เพื่อบังคับการเชื่อมต่อผ่านพอร์ต 53 (DNS Port) ทั้งหมด ทั้งที่เป็น TCP และ UDP ให้วิ่งมาที่ตัว Mikrotik เพียงอย่างเดียว ใช้คำสั่งดังด้านล่างครับ จึงนำมาแบ่งปันกัน เผื่อใครกำลังพบปัญหา หรืออาจจะพบปัญหาในอนาคต
สามารถแก้ไขตรง 192.168.100.1 เป็น IP Mikrotik ของท่านได้

/ip firewall nat

add chain=dstnat action=dst-nat to-addresses=192.168.100.1 to-ports=53 protocol=tcp dst-port=53

add chain=dstnat action=dst-nat to-addresses=192.168.100.1 to-ports=53 protocol=udp dst-port=53

Facebook Comments
%d bloggers like this: